中企动力 > 商学院 > 北京市数据恢复
  • ?

    北京四号线故障:运营秩序正逐步恢复

    贲鹏飞

    展开

    原标题:北京四号线故障致部分列车行车间隔加大

    据北京地铁公司官方微博消息,目前,因地铁四号线上行(开往安河桥北站)一列车运行至菜市口站区间发生故障,部分列车行车间隔加大。

    延伸阅读

    北京地铁1号线一乘客充电宝突然冒烟 部分列车晚点

    7月10日上午8点半左右,地铁1号线大望路站,一乘客的充电宝突然冒烟,此事造成了部分地铁列车晚点。

    事发时正值早高峰,一位目击者表示,列车是从四惠到大望路路途中,突然车厢内人群躁动。“我本以为是发生占座打架,后来发现车厢冒烟,人群疯狂的往车尾跑。”直到最后跑下了车,他才知道冒烟的是一个充电宝。

    也有网友表示,事发时地铁车厢里烟味儿特别大,还有一个女孩儿的行李箱在混乱之中丢了,有几位乘客还有不同的碰伤。

    根据北京地铁官方微博的信息,8:43地铁1号线列车(开往苹果园方向)行驶至大望路站时,车厢内一乘客携带充电宝冒烟,工作人员现场处理后列车恢复正常运营,此事影响部分列车晚点。

  • ?

    格式化硬盘数据恢复 如何找回格式化删除的文件

    敦刻尔克

    展开

    有接触过电脑工作的人相信对格式化这个操作都知道,它可以彻底的将一个分区中的文件给直接永久的删除掉,是用来整理分区的一种方式,也是用来检测硬盘是否完好的一个方式,那么如果格式化删除的数据有需要的那该怎么找回呢?

    格式化删除的文件比永久删除的文件找回要麻烦一点,毕竟这是删除整个分区的东西,不过有一款软件非常的不错---强力数据恢复软件,它能在短时间内将格式化删除的文件给找回来,一起来看看吧。

    第一步:在常用电脑的浏览器上搜索“强力数据恢复软件”,将软件下载安装至电脑上,随后打开软件,界面上有两种的扫描模式,因是格式化删除的文件,所以这里选择“深度扫描”模式。

    第二步:接下来界面上出现有电脑的分区信息,在其中找到之前进行过格式化的那个分区,选中之后点击“开始扫描”按钮,软件就开始对选中的分区进行深度的扫描了。(提示:如果知道删除的文件格式可以点击“文件设置”来设置扫描文件的类型可以减少扫描时间)。

    第三步:扫描结束之后,在界面结果左侧找到文件格式点击,旁边出现有具体的文件信息,在其中勾选上之前误删的文件后点击“下一步”按钮。(双击右侧文件可以预览文件的详细信息,更好的确认是否为需要的文件)。

    第四步:点击“浏览”按钮自定义选择好文件恢复后的存储位置之后,点击“恢复”按钮,软件就对选中的文件进行恢复操作了。(选择存储位置的时候避免之前进行过格式化操作的分区)。

    使用了强力数据恢复软件进行了几个简单的操作之后,因格式化误删的文件就找回来了。

  • ?

    北京市25条老胡同将恢复旧名称

    石器

    展开

    北京多条老胡同恢复旧名。 北京晚报 图 北京青年报7月5日消息,站在繁华的西单街头,问及果匣胡同在哪里,很多人连连摇头,但要问明珠商场怎么走,路人会热情指点。其实明珠商场西侧的小路就是果匣胡同,只不过果匣胡同的名字已消失多年。今年,市规划国土委在对第二批无名路命名中,恢复了果匣胡同等25条老胡同的旧名。 据记载,位于西单横二条西侧的果匣胡同北起堂子胡同,南至小石虎胡同,呈南北走向。附近的老住户告诉北京青年报记者,胡同原来叫火匣子胡同,后来取谐音改成果匣胡同,上世纪60年代果匣胡同并入了小石虎胡同后,胡同名就消失了。现在,已经很少有人知道西单明珠商场西侧那条曾经热闹的“小吃街”就是当年的果匣胡同。 4日上午,北青报记者在果匣胡同旧址看到,目前果匣胡同还没有路牌,胡同长约130米,原来位于胡同东侧底商的大鸡排、卤肉饭、奶茶店、排骨饭等人气小吃店已经关张,经过整治,胡同变清静了,花池子里栽种着花卉和绿植,不少游人坐在路边的长椅上休息。 同果匣胡同一样,位于东城区草厂三条的南翔凤胡同也即将恢复旧名。北青报记者寻找南翔凤胡同的过程颇费周折,百度地图上虽然有南翔凤胡同,但却找不到具体的位置,最后在西兴隆街与草厂三条路口的东北角,才发现门牌写有南翔凤胡同的居民院。 居民黄先生告诉北青报记者,原来翔凤胡同是以洪福胡同为界,北侧是北翔凤胡同,南侧为南翔凤胡同。前些年草厂三条道路拓宽,南翔凤胡同被拆除,目前只剩下3个居民院,虽然没有路牌,但门牌号还保留着南翔凤胡同的名字。 据史料记载,翔凤胡同形成于明末清初,那时前门地区商贾云集、会馆林立,原来打磨厂和崇祯观一带的房子不够住,居民就见缝插针,向两侧延伸,在空地上盖起了房子。当初因胡同比较狭窄,当地的百姓管它叫墙缝胡同,新中国成立之后才改名为翔凤胡同。

  • ?

    从删库到跑路or恢复,记一次MySQL数据库文件损坏恢复经历

    万仇

    展开

    一、 前言

    2018年5月28日,北京晴有轻度沙尘暴。 坐上公交车走在上班的路上,想起老罗经常说起的一句话:想成盛田昭夫时代的索尼,想成乔布斯时代的苹果,于是继续研读着 《日本制造:盛田昭夫的日式经营学》。

    到了人大西门在西区食堂吃了个早餐,穿过人民大学很快就来到了公司。坐在工位上打开电脑登上QQ,不一会运营的CC的头像就开始闪动,“mooc平台登录不了”,“你看看”。又一会领导的头像开始闪动,“xxx说慕课平台不能登录了”。 额… 这事都惊动领导了?

    二、 排查问题

    打开chrome浏览器开始预览,等了好久代理服务器才反馈

    Time out!

    使用 SecureCRT 连接了一下服务器,首先重新启动了一下Nginx代理服务器

    service nignx stop // 关闭Nginx服务 service nginx start // 开启Nginx服务

    去前台刷新了几下没有恢复。 那就在重启一下php吧,于是就

    service php-fpm stop // 关闭PHP服务 service php-fpm start // 开启PHP服务

    又去前台试了试还是没有恢复。(有人会问为什么不直接用 service xxx restart 来重启各服务呢? 我也不知道为什么,个人爱好吧!)那只有一种可能数据库出问题了。

    打开 Navicat 连接了一下数据库,发现可以正常连接而且可以看到所有的表,随便打开了一张表能看到里面的数据,但是弹出了一个错误的提示。

    Got error 28 from storage engine

    大概是这个错误提示,当时也没在意,心想反正提示错误了那就重启一下物理服务器吧,这里是物理服务器!!!随后执行了这个命令(为什么不直接重启MySQL服务呢? 事后想了想我也不知道为什么。 而且如果当时注意看看这个错误,是因为磁盘空间问题引起的,也许后面就不会有那么多惊心动魄了!)

    reboot // 重启物理服务器

    执行完以后所有的服务都正常关闭了,只有Mysql数据库服务

    Shutdown MySQL ……………………………………………….

    引号已经5排了,实在是等不下去了。 断电!!!(MySQL没有安全关闭,直接断电会出问题的!!!)。

    三、 恢复进程

    等了一会,物理服务器启动起来了。一切的应用服务都正常启动了,只看到在启动MySQL数据库的时候出现了

    The server quit without updating pid file (/var/lib/mysql/localhost.localdomain.pid)

    等到全部服务加载完成以后手动又进行了一次MySQL数据库启动

    service mysql start

    依然报前面那样的错误,此时心里开始紧张了起来。 Google了一下这个错误,网上提供了几种解决的方案:

    1、 Mysql权限问题

    chown -R mysql:mysql /var/lib/mysql/* chmod -R 660 /var/lib/mysql/*

    2、 Mysql 服务已开启

    ps -ef|grep mysqld // 查看是否有mysqld进程 kill -9 进程号 // 强制杀死进程

    3、 残余数据影响了Mysql服务的启动

    删除数据库目录(我的数据库目录为rpm安装默认目录:/var/lib/mysql)下的 mysql-bin.index 文件

    4、 Mysql配置文件(默认为:/etc/myf)

    配置文件里面没有配置数据库目录,这个问题一般在刚安装MySQL时候会出现

    5、 skip-federated字段问题

    MySQL配置文件注释掉skip-federated字段

    6、 selinux的问题

    centos6.8以上默认会开启selinux服务,加强版军用级防火墙。为了查问题可以直接关掉 /usr/sbin/setenforce 0

    以上解决方案全部都已经使用过了,都没有解决问题,依然开启服务会报错。 此时的心开始凉了。

    回头看了看往期的备份,xxxx_20171208.sql。 都快2018年6月份了,我的上次备份竟然是17年12月份的,半年了!都半年没备份过了! (我视乎隐约的感觉前段时间是有备份的,备份的服务器硬盘好像被我清理了)。

    进入到数据库目录下,看到了除了上述说的 mysql-bin.index 文件以外还有其他的几个文件:mysql-bin.~rec~ 、 ib_logfile1、 ib_logfile0、 ibdata1 想了想是不是这几个也是一些残余文件,全部删了试试。 尝试把这几个文件转移到了其他的目录(使用的mv命令)模拟删除效果,同时还相当于备份。

    service mysql start

    竟然MySQL数据库服务正常启动了! 心里的喜悦涌了上来,赶紧使用Navicat连接一下看看,能够正常连接,看到了数据库。 打开数据库以后所有的表都没有了! 此时心又酸了起来。 一转眼11:30了,时间过的可真快啊,同事叫着一起吃饭,此时的我已经全无吃饭的心情了。

    恢复表结构

    把刚才移走的几个文件又恢复到了原目录里,既然恢复MySQL进程现在没什么希望了,那就想办法恢复数据吧。 进入到数据库目录(/var/lib/mysql)下找到了我的数据库名字以目录的形式存放。 进去该目录以后发现里面都是以扩展名为:xxxx表.frm文件,这些不都是我的数据库表吗? 里面是不是就存放了所有的数据? 是不是直接拿这些文件就可以恢复数据呢?Google了一下,果然有这方面的文章,大致说: “frm可以恢复表结构,同时InnoDB数据库引擎和MyISAM数据库引擎恢复的方式不一样”。

    1、 InnoDB数据库引擎

    在一个正常的MySQL数据库服务器(new_server)下建立数据库(new_db),该数据库的名称和异常服务器(old_server)数据库(old_db)保持一致。在new_db数据库中建立一张表与old_db的表名称(t_user)一致。将new_server服务器的MySQL数据库服务关闭。从old_server服务器下old_db的数据库目录下复制t_user.frm文件到new_server服务器下new_db的数据库目录下替换t_user.frm文件。开启new_server服务器的MySQL数据库服务。使用连接工具连接new_server就可以看到new_db下的表及表结构。

    2、 MyISAM数据库引擎

    其他和InnoDB数据库引擎操作基本一致,只是在new_server服务器下new_db的数据库目录下创建两个空的文件:t_user.MYD 和 t_user.MYI。

    我使用的数据库为InnoDB引擎,无奈的我以上两种方法都使用了,没有恢复任何表结构更没有数据,也许可能是我操作有问题吧。 此时看到了目录下有一个文件: ibdata1 Google了一下,可以和xxx.frm配合使用,又一次将new_server服务器的MySQL数据库服务关闭。 直接把old_server服务器下old_db的数据库目录下复制ibdata1文件到new_server服务器下new_db的数据库目录下替换ibdata1文件。

    service mysql start

    新的服务器也出现了这样的错误,导致错误的很大原因可能是ibdata1文件损坏引起的。

    今天北京的天气已经达到了35摄氏度,但此时我的心已经凉了一半了,虽然没有按时备份数据及服务器异常崩溃造成数据丢失比直接删库的责任小了点,但是也办法向公司交代,真的需要开始准备 “离职申请” 了吗?

    binlog日志

    打开微信

    我:你们公司用的是什么数据库,是MySQL吗 好友LZ:是的 我:公司的MySQL坏了,启动不了了; 数据没有备份; 有什么好办法把数据拿回来吗 好友LZ:你们之前数据的binlog还有吗;通过这个应该可以恢复 我:都有 好友LZ:我也没弄过数据恢复,都是DBA搞,感觉应该可以的;你先查查看网上有没有解决方案,我这会在上线。 我:嗯

    本来想说:“你能不能问问好友LZ你们DBA遇到过这种情况吗,帮忙给个方案”;最后还是没有好意思开出口。 不过binlog这个名字让我突然想起了数据库目录(/var/lib/mysql)下面几个较大的文件。

    这十几个文件就是binlog日志文件,每台服务器上面的个数应该不一样,这个文件只有每次重启MySQL服务或者刷新日志(MySQL命令:show master logs)的时候才会新增一个。看了一下我最近的几个文件,2018年1月16、 2018年3月18、 2018年4月18、 2018年5月28这几个时间点产生了新的文件,说明MySQL服务器这几个日期都进行过关闭又开启的操作。

    binlog使用:

    binlog文件简介(网上摘抄) MySQL的二进制日志可以说是MySQL最重要的日志了,它记录了所有的DDL和DML(除了数据查询语句)语句,以事件形式记录,还包含语句所执行的消耗的时间,MySQL的二进制日志是事务安全型的。 binlog作用(网上摘抄) MySQL Replication在Master端开启binlog,Mster把它的二进制日志传递给slaves来达到master-slave数据一致的目的。 数据恢复,通过使用mysqlbinlog工具来使恢复数据。

    使用binlog恢复数据之前需要确定MySQL是否开启binlog日志

    show variables like 'log_%';

    状态 OFF 为未开启,状态 ON 表示已开启

    可以通过MySQL配置文件(默认路径:/etc/myf)开启或关闭binlog日志

    vi /etc/myf

    使用加上#可以关闭,去掉开启。 修改后需要重启MySQL服务(service mysql restart)才可以生效。

    恢复数据(binlog日志方式)

    初试mysqlbinlog工具

    看到上面的那么多mysql-bin文件,很显然使用centos6.5下rpm方式安装的MySQL默认是打开binlog日志的。 这时我们就需要用到MySQL的 mysqlbinlog 工具,想使用它首先需要确保已经安装MySQL服务,然后我们需要找到它的位置

    find / -name mysql

    2 表示为MySQL可执行文件的目录 3 表示为MySQL的数据库目录

    那我们先简单的使用一下

    cd /var/lib/mysql mysqlbinlog mysql-bin.000001 >mysql-bin.000001.sql

    很显然我在使用mysqlbinlog的时候是,直接执行的mysqlbinlog命令,前面并没有增加任何路径。 因为默认centos系统会将/usr/bin这个目录配置到环境标量中,若我们使用的是rpm方式安装的MySQL,默认是安装到/usr/bin目录下的。 可以直接在任何路径下使用/usr/bin目录里的文件。 执行完上面的语句后会发现在当前目录生成一个mysql-bin.000001.sql的文件, 打开文件可以看到很多sql语句。

    对于我当前的情况来看并不需要把所有的binlog都处理一遍,上面提到我上次的备份是在2017年12月8日的时候(xxxx_20171208.sql)因此我只需要从 mysql-bin.000009 这个binlog文件开始就可以了。

    首先我在另外一台服务器上面重新搭建了一个MySQL服务,把mysql-bin.000009以后的几个binlog都拷贝到了这台新的服务器上面去。(服务器出现任何问题,建议不要对该服务器做任何操作,换一台新的电脑或服务来处理,为了保护数据的完整性!)

    使用备份文件恢复数据

    在新的MySQL上面建了一个和以前一样名称的数据库

    mysql -u数据库用户名 -p数据库密码 数据库名称 --default-character-set=utf8 < xxxx_20171208.sql 例:mysql -uroot -proot xxxx --default-character-set=utf8 < xxxx_20171208.sql

    使用binlog恢复数据

    这时数据库有了,数据表及表结构也有了,那就开始恢复数据吧。

    mysqlbinlog mysql-bin.000009 | mysql -uroot -proot

    回车马上就出错了,遇到了两种错误,一种是PRIMARY的错误,一种是找不到记录的错误。 mysqlbinlog在执行mysql-bin.000009文件里的插入语句时出错了。 看了一下mysql-bin.000009文件的创建时间是2017年11月12日,我的备份文件是2017年12月8日,他们两个时间差了二十几天,执行上面恢复语句肯定会出现重复插入的问题,数据库里的某些表是由PRIMARY KEY的约束的,所以会导致PRIMARY错误。 这时我们需要用到mysqlbinlog的参数: start-datetime 和 end-datetime,顾名思义一个是开始时间一个是结束时间。

    mysqlbinlog --start-datetime="2017-12-08 10:00:00" mysql-bin.000009 | mysql -uroot -proot

    看了一下我备份的xxxx_20171208.sql大致是2017年12月8日的10左右,没有添加 end-datetime 参数的话默认为该binglog文件下的最后一个时间点。 执行了以后报了一个找不到记录的异常。 应该是执行删除或更新语句的时候没有找到某条记录,时间还是不对。 于是我就查看了数据库的日志表,最后的时间是2017年12月8日9点32分41秒,有执行了一次

    mysqlbinlog --start-datetime="2017-12-08 09:32:41" mysql-bin.000009 | mysql -uroot -proot

    依然报错,那怎么办呢,难道这个方法不行?

    mysqlbinlog mysql-bin.000009 >mysql-bin.000009.sql

    此时打开mysql-bin.000009.sql里面拥有大量的sql语句,发现好多条sql语句在这个时间点下。 看来使用参数来控制行不通。 还好mysqlbinlog工具给我们提供了另外两个参数start-position 和 end-position

    修改了一下命令

    mysqlbinlog --start-position="123456" mysql-bin.000009 | mysql -uroot -proot

    果然一切都正常了,执行这个命令需要很久,它要把你这段时间所有的增加、删除、更新都执行一遍。 这里可能还会遇到一个问题,我的这个MySQL服务器里面这有一个数据库,MySQL的binlog文件记录的是所有数据库的增加、删除、更新记录,那怎样只针对某个数据库来操作呢? 这时我们需要用到mysqlbinlog的database参数

    mysqlbinlog --database=xxxx --start-position="123456" mysql-bin.000009 | mysql -uroot -proot

    半年的数据,就这么一个一个的binlog文件进行处理的,从晚上6点到夜里的12点完成所有文件的恢复,数据量不是很大,服务器的性能也不是太高,中间出了点问题,不过都是服务器中断的问题。 最后把所有的数据全部恢复了回来,这心惊肉跳的一天!

    这是工作7年来出的最大一次事故,去年给自己定的一个目标今年写12篇有质量的文章反馈给互联网,都快过半年了ä...

  • ?

    服务器瘫痪怎么办-恢复服务器数据的两种方法

    支凡桃

    展开

    【服务器数据恢复介绍】

    北京某公司的一台服务器在正常运行过程中因为未知原因忽然崩溃,管理员对服务器进行检查发现有一块硬盘离线,只需更换故障硬盘即可,于是管理员对服务器进行更换硬盘并同步数据,但是在更换新硬盘后进行数据同步的过程中服务器中的另一块硬盘又忽然掉线,如此一来客户的服务器彻底瘫痪了,逻辑盘无法挂载,进入服务器的管理界面查看发现有两块硬盘的状态为故障脱机

    【服务器数据恢复备份】

    服务器数据恢复的第一步也是必须要做的一步就是对故障服务器进行全盘备份,因为在数据恢复的过程中不可避免的要对数据进行分析和数据重组工作,并且这些工作往往需要进行多次重复分析和提取,如果在原始设备上进行分析重组必然会对服务器的原始数据进行破坏,如此一来一旦由于数据恢复工程师技术原因导致数据恢复失败的话就会导致原始服务器内的数据被破坏,其他数据恢复公司再进行数据恢复操作时难度增加甚至导致原始数据被彻底损坏无法恢复。所以在进行服务器数据恢复时首先要对服务器内的所有磁盘进行备份操作,在进行备份时数据恢复工程师们大多借助数据恢复工具进行全盘镜像(尤其是有故障的硬盘必须使用专业设备进行备份,普通方法无法进行镜像操作)

    【制定服务器数据恢复方案】

    服务器数据恢复方案一、如果离线硬盘没有物理故障那么对服务器进行强制上线操作是修复服务器故障的最简单的方法,一般情况下将后离线的硬盘进行故障修复,然后重新连接服务器后进行强制上线即可,如果故障硬盘离线的原因是硬盘物理故障那么强制上线不仅会失败而且还会增加raid卡负担,是无法通过强制上线进行恢复数据的。另外即使硬盘不存在物理故障采用强制上线的方法进行数据恢复也存在着一定的风险,我们都知道服务器强制上线后会进行重建,在重建过程中一旦检测到服务器中其他硬盘存在故障那么服务器就可能面临彻底崩溃。由于我们是专业的数据恢复公司,所以本次数据恢复中采取了另一种更为稳妥的数据恢复方案。

    服务器数据恢复方案二、通过分析底层数据结构提取原服务器数据。这种数据恢复方案的原理是首先根据服务器的原始配置信息将所有硬盘按照Mdisk组进行分类,分析每一组Mdisk的raid基本信息,然后借助专业的数据恢复工具虚拟重组出Mdisk,然后再对重组的Mdisk进行进一步分析,得到pool信息和pool在Mdisk上的分布情况、pool的条带大小、各lun在pool中的分布情况这些基本信息,然后由服务器数据恢复工程师编写一个小程序进行lun的提取。

    【服务器数据恢复结果迁移】

    服务器数据恢复工程师将提取出的lun进行验证后将提取出的lun使用dd的方式迁移到新的服务器中,本次服务器数据恢复成功。

  • ?

    国家出面协调 顺丰和菜鸟数据恢复互通

    钱思天

    展开

    近日,顺丰和菜鸟网络互相封杀,引起了国内用户的关注,双方都各持说法,没有退步的打算。继第一次协调后,国家邮政局再次出手,昨天晚上对菜鸟和顺丰进行协调,并最终给出了公告,今日12时起双方全面恢复各自数据传输。

    今天凌晨3时56分,国家邮政局官方微信公众号发布《国家邮政局协调解决菜鸟顺丰数据互通问题》的文章显示,国家邮政局召集菜鸟网络和顺丰速运高层来北京,就双方关闭互通数据接口问题进行协调。双方表示,将从讲政治顾大局的高度出发,积极寻求解决问题的最大公约数,共同维护市场秩序和消费者合法权益,并同意从6月3日12时起,全面恢复业务合作和数据传输。

    对于这次两家巨头的“打架”,国家邮政局强调,近年来电商与快递业共同发展的良好态势来之不易,应倍加珍惜。希望上下游企业共同努力,携手共进,合力推动行业持续健康发展,为广大消费者提供更好的快递服务。

  • ?

    数据还原丨北京房租高吗?

    意深远

    展开

    租金作为房屋租赁市场供需关系的标志,其高低既关系到租客的负担,又关系到业主的出租意愿,也关系到购租并举的市场供给体系。我们借助于链家租赁成交的数据,回顾和比较北京租金水平的变化,探索其内在的原因。

    一、北京租金水平变动情况根据链家成交数据,过去5年,北京租赁市场的租金水平总体呈现上涨态势,租金年均上涨6%。2016年北京成交的平均租金水平达到每月69.2元/平方米,比2015年上涨15.8%,比2012年上涨26.6%。

    从月度看,2013年至2015年,北京租金涨幅总体呈现回落态势,2015年月度同比涨幅甚至出现小幅下跌。2016年开始,租金涨幅迅速扩大,年底涨幅达到24%。这里既有基数低的原因,也是因为2016年整个房地产市场处于明显的上升期。2017年以来,租金涨幅快速回落,6月份涨幅为10%。受去年高基数和市场降温影响,今年下半年租金涨幅进一步回落甚至有所下跌。

    二、北京租金水平的特点一是租金涨幅远低于房价。近5年,北京二手房房价年均上涨14.3%,租金涨幅比房价涨幅低8.3个百分点。从时间上看,租金的变动比房价更平稳,2013年、2015-2016年买卖市场活跃时,房价涨幅远高于租金。2014年下半年,市场下行期间,房价跌幅大于租金。2016年5月份之后,房价租金涨幅出现背离,房价与租金涨幅的差距明显扩大。2017年租金领先房价涨幅出现回落。目前,房价涨幅比租金高36个百分点。

    二是租金涨幅超过CPI。近5年,北京居民消费价格指数CPI年均上涨2.3%,租金年均涨幅比CPI高出3.7个百分点。从时间序列看,2013-2014年一季度,租金涨幅高于CPI,2015年租金同比下跌。2016年3月份以后,租金同比涨幅与CPI的差距快速扩大,到年底12月涨幅比CPI涨幅高22个百分点。今年以来,租金涨幅出现回落,但仍然比CPI高10个百分点。

    三是租金涨幅低于居民收入,2016年超过收入增速。与买房置业相比,租赁是相对刚性需求,租金水平应该与人们的收入水平相匹配。近5年,北京城镇居民人均可支配收入年均增长率为9%,租金水平年均涨幅比居民收入低3个百分点。部分年份租金涨幅超过收入,2016年北京市租金涨幅超过城镇居民收入增速7.4个百分点。

    四是租金在个人收入中占比较低。根据链家研究院调查,目前北京租客的租金支出一般占个人收入的25%左右,远低于纽约、伦敦、东京、香港等国际一线城市的成熟租赁市场。租金收入低导致租赁回报率低下,房东宁可空置也不愿拿房出租,专业运营机构也面临盈利的困境。随着购租并举政策的实施,北京租赁市场将更加成熟,未来租金水平有向发达国家一线城市租赁市场靠拢的倾向。

    三、影响租金价格变动的原因一是市场供求关系。2016年,北京常住人口2173万,其中常住外来人口807万,按照占常住人口30%计算,租赁人口约为652万,以户均3人计算,需要租赁房屋超过220万套。目前可供租赁的房屋150万套,缺口大约在70万套。北京链家近5年租赁市场客源数量与房源数量之比始终大于1,意味着市场供不应求,这是近几年北京平均租金水平上涨的主要因素。随着北京未来大量增加租赁供应,供不应求的矛盾将来或有所缓解。

    二是居民的支付能力。与加杠杆购房不同,租赁市场基本没有金融杠杆支持,租金水平是由居民支付能力支撑。支付能力包括居民实际收入水平与支出占比。居民收入水平不断提高是租金水平能够上涨的条件。近年来,北京城镇居民可支配收入增速放缓,不支持租金水平大幅上涨。

    三是货币金融环境。作为居民消费价格的一项,租金也受到货币环境影响,流动性越充裕,价格上涨越明显。2013年到2015年一季度,租金涨幅与M2增速同步回落,2015年4月到2016年3月,M2增速回升,导致2016年租金涨幅扩大。2016年4月份以后,M2增速逐渐回落,在一定程度上导致租金价格在12月以后涨幅回落。未来,货币供应量如果不出现加快,租金水平也将难以大幅上升。

    四是房价快速上涨的传导。房屋买卖市场与租赁市场的互补。当买卖市场火爆时,租转售比例上升,租赁供给减少,从而引起租金上涨。反之,市场低迷时,售转租比例的增加带来租赁供给的增加。2016年以来北京房屋价格大幅上涨带动了租金价格的上涨。2016年北京二手房房价上涨了28.2%,同期租金上涨了15.8%,远高于过去4年3%的年均复合增长率。

    五是产品服务升级的影响。长租公寓的出现满足了人们对于租赁品质的需求,解决了普通租赁过程中房源品质差的问题,因而长租公寓是普通租赁产品的升级产品,其中包含更多的价值,因而应该具有更高的价格。此外,长租公寓运营企业相较普通业主需要承担更多的运营成本和税收成本,这些成本最终将反映到产品价格中。目前市场上的长租公寓产品相较周边普租型同类产品定价高10%-20%。

    六是房屋位置的影响。房屋作为不动产,位置是影响居住体验的重要因素,租金价格受位置影响较大。一般来说,距离市中心越近的地区拥有更好的市政配套和交通能力,因而中心城区租金水平较高。

    从环线看,由于北京单中心城市格局的特点,二环至六环之间的租金水平依次递减。北京二环以内租金水平最高,达到102.12元/平方米,六环以外租金水平最低,为39.25元/平方米,值得注意的是,四环—五环间租金水平与五环—六环间租金水平差距最大,且差距逐年扩大,2016年两个环线区域间租金差超过21.65元/平米/月。

    分区域来看,朝阳、东城、海淀、西城等中心城区单平米租金水平明显高于其他城区。而近郊中大兴、通州、顺义租金水平则相对较低。近五年东城、西城、朝阳、海淀、亦庄开发区、昌平等区域的租金增速明显快于其他区县。

    学区房和地铁房的租金上涨速度明显快于非学区房和非地铁房。学区房租金上涨速度较快主要与样本学区的位置更多在内城区以及自身的学区属性有关。一方面内城区房屋周边交通和配套设施完备,另一方面学区的特殊属性造成了局部空间中市场房源更多供应于交易市场,造成了该地区租赁房源短缺,从而导致学区的交易价格上涨速度快于整体市场水平。

    从上述影响租金的因素看,未来一两年,金融环境、居民收入以及房价对租赁的传导动力都较弱,租金大幅上涨的可能性不大。但产品品质的升级和区域变动可能会对租金水平产生结构性的影响。注:本文中数据来自链家成交,不完全代表全市场水平。

  • ?

    信诺科技:关于磁盘阵列的数据恢复

    Yin

    展开

    提到磁盘阵列呢,一定要说一下目前最常见阵列之一Raid5。

    它本身也具有一定的数据保护机制,如果其中的一块盘坏了,插上新磁盘后,将会自动通过其他磁盘上的校验码实现数据恢复。

    但是,这样的机制对于数据保护机制是不够的,万一出现下面这些情况亲们就手足无措啦Y(^_^)Y

    图片来自网络

    1、缺陷磁盘可以恢复数据

    在大多数情况下,在两个有缺陷的磁盘上可以恢复数据。

    但是,至少需要清洁室中的两个故障硬盘驱动器中的一个被恢复。

    之后,可以从碎片和奇偶校验数据中挽回剩余的RAID 5数据。

    小诺建议亲们尽可能使用手动和专有的半自动程序保存数据,这样会有很高几率挽回损失。

    2、哪些文件系统允许RAID 5数据恢复?

    在RAID 5阵列发生故障的情况下,使用操作系统(Windows,Linux,MacOS等)和RAID卷上使用的文件系统在数据恢复中起初不起决定性作用哦。

    因此所有文件系统都是可行的哦。

    NTFS(Windows)、FAT32(Windows)、Ext3,Ext4、BtrFS(各种NAS制造商,Windows,Linux)、HFS / HFS +(苹果/ Mac)、APFS(也是Mac)、vmFS(vmWare文件系统)

    当涉及到删除数据,格式化的RAID驱动器和其他逻辑损坏(快照删除等)时,所使用的文件系统与数据恢复工作以及成功的可能性相关得多呢。

    3、RAID 5磁盘置换

    任意更换RAID 5中的磁盘顺序都会导致RAID数据的大量混乱。

    通常会导致不必要的数据错误覆盖,从而导致进一步的逻辑损坏。

    因此在亲们删除磁盘之前,记录顺序并将其标记在硬盘上是非常重要的。

    4、RAID5重建时间

    RAID重建(即RAID 5数据在故障和更换硬盘后重新组织)通常不会太长。

    当然,重建的时间取决于硬盘的大小和数量,以及整个系统(服务器速度,控制器等)。

    如果重建持续数天,则可以假定有错误。

    通常在这一点文件系统的致命的损害,这只能通过专业的数据恢复恢复。

    5、RAID5的数据恢复不需要控制器

    对于RAID 5的数据恢复,亲们并不需要RAID控制器。

    恢复总是多层次的。首先,个人硬盘,如果有缺陷,重建。

    之后,原始数据被虚拟地恢复到RAID阵列。

    然后通过手动步骤和专门开发的技术重新构建经常存在的不一致性。

    因此RAID控制器不是必需的。

    6、NAS数据缺失可以恢复

    RAID 5数据恢复是可能的,以及服务器/存储系统以及NAS(网络附加存储)。

    NAS通常不使用标准化的RAID5配置,而是使用专有的所谓专有RAID阵列。

    虽然这些特定的配置大多是基于标准的RAID,但是它们的布局大都是无证的,所以数据恢复成本通常更高,亲们根据自身情况酌情选择。

  • ?

    东北数据恢复领导品牌——海鹏数据恢复中心

    zxcvzxcv

    展开

    海鹏数据恢复中心始创于1998年2月28日,是国内首批成立的专业数据恢复机构,是东北地区久负盛名的专业数据恢复中心。目前,海鹏数据恢复中心在船舶电子大世界、教化电子大世界、泰山电子城三大IT卖场中均设有直营分支机构,主营业务包括数据恢复、硬盘维修、U盘修复、电子取证、手机恢复、监控恢复、服务器修复……等。海鹏数据恢复中心拥有众多原装进口世界著名正版数据恢复软硬件设备与工具,21年来始终专注于为各大企事业单位、机关院校、公安部队、个人客户……提供质优价廉、安全可靠的本地化高水准技术服务。

    海鹏数据恢复中心拥有众多原装进口世界顶级正版数据恢复软硬件设备与工具,包括ACE PC-3000全系列、Salvation全系列、DataExplore全系列、HRT全系列、MRT全系列、SRT全系列、RCT全系列……等等,多年来始终专注于为各大企事业单位、机关院校、公安部队、个人客户……提供质优价廉、安全可靠的本地化高水准技术服务。 

    海鹏数据恢复中心可以挽救台式机硬盘、笔记本硬盘、移动硬盘、服务器硬盘、RAID磁盘阵列、U盘、MP3/MP4、录音笔、数码卡、光盘、数码相机、数码摄像机、安防监控、文件修复、数据解密、手机、特殊存储介质(如软盘、MO盘、MD盘、苹果iPod、松下P2卡)、特殊操作系统(如Linux、Unix、Netware、iOS)……等各种类型的数据损失,整体技术已位居东北领先、国内上游的水平,部分技术已达到国内领先水平。

  • ?

    了解什么是专业数据恢复

    人情味

    展开

    数据恢复是指通过技术手段,将保存在台式机硬盘、笔记本硬盘、服务器硬盘、存储磁带库、移动硬盘、U盘、数码存储卡、Mp3等等设备上丢失的电子数据进行抢救和恢复的技术。

    不同的存储设备的储存原理不一样,所以需要针对不同的情况再做分析和处理。理论上讲只要数据没有被覆盖,数据就有可能恢复回来,但也要强调由于数据有碎片,所有恢复出来的问价不一定都是原始文件或者是损坏的,无法打开使。普通的数据公司一般是使用软件来进行扫描数据进而恢复,但当发生硬件故障往往无法处理。例如硬盘开盘时需要无尘的环境保证盘片不手损伤,U盘等存储卡的FLASH芯片发生损坏时需要进行匹配和修复才能提取数据,针对不同格式的文件需要重新编程算法才能找到文件。

    专业的数据恢复公司有专业的设备对于存储设备进行检测,有专业的工作环境保证存储设备元件的更换和处理,有专业的工程师针对不同的情况进行相应的处理,能让客户享受专业的技术服务,保证数据的完整性和安全性,能最大限度的节省客户的时间。

    再次提醒大家多多进行数据恢复。

北京市数据恢复

所有视频需要登录后,才能观看

请先登录您的帐号,即可完整播放,如果您尚未注册帐号,请先点击注册。

img

在线咨询

建站在线咨询

img

微信咨询

扫一扫添加
动力姐姐微信

img
img

TOP